HITMAN - New Companion App Released; Toughest Elusive Target Coming July 15th

COPENHAGEN, July 7, 2016 - Io-Interactive launches a new companion app for HITMAN and confirms the next Elusive Target, called ‘The Twin’.

Companion App - The HITMAN companion app is now available to download for iOS and Android phones and will ensure players can keep up-to-date with all the live HITMAN content on the go. In addition to the episode releases, new content in the form of Elusive Targets, Escalation Contracts and Featured Contracts, have been released every week since the game launched in March 2016 – all details will be updated in the HITMAN companion app. With Elusive Targets, players will be able to use the app whilst playing to keep their latest target’s image visible as they hunt for their target in game.

The app is free to download now.
Download the App Now for iOS*: http://bit.ly/HMCompanion_iOS
Download the App Now for Android**: http://bit.ly/HMCompanion_Android

Elusive Target - The next Elusive Target will go live on July 15th. The target is Dylan Narvaez, aka ‘The Twin’, who will be in Sapienza for 72 hours. His identical twin brother, Gonzales is also in Sapienza and must not be harmed in any way or the contract will be cancelled.

Elusive Target Contracts make changes to the existing locations and use advanced AI behaviour to create a more believable and challenging experience for players. So players cannot rely solely on what they already know from the location or on any routines from the characters in the sandbox locations. Elusive Targets are designed to be difficult and ‘The Twin’ is arguably the toughest one yet..!

If you complete 5 Elusive Target contracts, you'll receive the Hitman Absolution suit as a prize

HITMAN is available on the PlayStation®4 computer entertainment system, Xbox One, the all-in-one games and entertainment system from Microsoft, and Windows PC.

*For iOS, the HITMAN Companion is compatible with the iPhone 4S and later, iOS 8 is required.
**For Android, API level 15 or above is required (“Ice Cream Sandwich” 4.0.3)